Better support for pyqt

Request Features and Feature Changes

Better support for pyqt

Postby ufechner » Sat Jan 17, 2009 6:25 pm

Hello,

I like Editra a lot.

QT will be LGPL soon, so there is no more reason to avoid it because of
it's license.

So I have same wishes:

1. a button to run QT-Designer (/usr/bin/designer-qt4), preferably with
the .ui file as argument, that is open.
2. a button to run QT-Assistant (/usr/bin/assistant-qt4)
3. a button to run mkpyqt.py with the directory of the current file as argument

Thanks a lot for your good work!

Regards:

Uwe Fechner
(Runnin ubuntu 8.04)
ufechner
Limited User
 
Posts: 3
Joined: Sat Jan 17, 2009 6:10 pm

Re: Better support for pyqt

Postby cody » Sat Jan 17, 2009 6:32 pm

Hello,

This will have to be done as a plugin. But it could be done very easily. If your interested in making a plugin to do this is all that would have to be done.

1) get the svn and copy the hello plugin in the 'Editra/plugins/hello' directory and rename it to whatever you want to call it.

2) Using the main window interface add menu items, or toolbar items to do what you want.

3) Set the event handlers to do the actions you wanted

Done ;)

If you did want to try this I am available to help, so let me know.


Thanks,

Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States


Return to Feature Requests

Who is online

Users browsing this forum: No registered users and 2 guests

cron