Problem Mac Lion: TypeError: argument of type 'NoneType' is

Report Bugs Here

Problem Mac Lion: TypeError: argument of type 'NoneType' is

Postby diceman » Fri Oct 14, 2011 6:36 pm

hello,
since I updated my mac on the latest version of the editra editors will not start anymore!

these logs taken from the console:


14/10/11 20:33:17,337 [0x0-0x43043].org.editra.Editra: Traceback (most recent call last):
14/10/11 20:33:17,337 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/__boot__.py", line 137, in <module>
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: _run('Editra.py')
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/__boot__.py", line 134, in _run
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: execfile(path, globals(), globals())
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 1164, in <module>
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: Main()
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 1056, in Main
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: _Main(opts, args)
14/10/11 20:33:17,338 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 1073, in _Main
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: editra_app = Editra(False)
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 90, in __init__
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: wx.App.__init__(self, *args, **kargs)
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: File "wx/_core.pyo", line 7981, in __init__
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: File "wx/_core.pyo", line 7555, in _BootstrapApp
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 209, in OnInit
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: self.profile_updated = InitConfig()
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: File "/Applications/Editra.app/Contents/Resources/Editra.py", line 822, in InitConfig
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: if os.path.sep in sess:
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: TypeError
14/10/11 20:33:17,339 [0x0-0x43043].org.editra.Editra: : argument of type 'NoneType' is not iterable
14/10/11 20:33:17,408 Editra: Editra Error
14/10/11 20:33:17,409 Editra: Editra Error
An unexpected error has occurred during execution of the main script

TypeError: argument of type 'NoneType' is not iterable
14/10/11 20:34:08,000 kernel: IOSurface: buffer allocation size is zero
14/10/11 20:35:13,579 com.apple.launchd.peruser.501: ([0x0-0x43043].org.editra.Editra[488]) Exited with code: 255

how can I fix this? :roll:
diceman
Limited User
 
Posts: 3
Joined: Fri Oct 14, 2011 6:31 pm

Re: Problem Mac Lion: TypeError: argument of type 'NoneType'

Postby cody » Fri Oct 14, 2011 7:56 pm

Hi,

Try to delete your Editra user profile. Will investigate issue for next release.

~/Library/Application Support/Editra

Can try to delete either the whole Editra directory listed above or just the profiles (Editra/profiles/*.ppb).


Thanks,

Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Problem Mac Lion: TypeError: argument of type 'NoneType'

Postby diceman » Fri Oct 14, 2011 8:06 pm

I do not have that directory

$ cd /Library/Application\ Support/
$ ls
Apple ProApps iLifeMediaBrowser
CrashReporter Script Editor iStat local
Microsoft avbdeviced
diceman
Limited User
 
Posts: 3
Joined: Fri Oct 14, 2011 6:31 pm

Re: Problem Mac Lion: TypeError: argument of type 'NoneType'

Postby cody » Fri Oct 14, 2011 8:27 pm

Hi,

Its under your home directory (~) not under root (/).

Code: Select all
cd ~/Library/Application Support/
rm -rf Editra
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Problem Mac Lion: TypeError: argument of type 'NoneType'

Postby diceman » Fri Oct 14, 2011 9:03 pm

ok perfect!! Now work :mrgreen:

thx for support
diceman
Limited User
 
Posts: 3
Joined: Fri Oct 14, 2011 6:31 pm

Re: Problem Mac Lion: TypeError: argument of type 'NoneType'

Postby cody » Mon Oct 17, 2011 1:56 pm

Thanks for reporting the issue.

Sorry for the inconvenience.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron