[fixed] Lexers menu not populated in Windows

Report Bugs Here

[fixed] Lexers menu not populated in Windows

Postby rgidney » Tue Nov 16, 2010 6:14 pm

I use Editra on both my Mac (Snow Leopard) and Windows (XP) and on my Mac Settings --> Lexers brings up the lexers selection and customize. In windows the Lexers selection is empty and customize shows all lexers us unselected and I can not add them to the menu. When I copy my Mac default.ppb file to my windows machine the lexers menu now has lexers displayed and usable but customize still does not function.

Thanks,
Bruce
rgidney
Limited User
 
Posts: 2
Joined: Tue Nov 16, 2010 6:05 pm

Re: Lexers menu not populated in Windows

Postby cody » Tue Nov 16, 2010 6:23 pm

Hi,

There was a bug in the menu customization dialog in 0.5.86 that has been fixed already for the next release.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Lexers menu not populated in Windows

Postby cody » Tue Nov 16, 2010 6:31 pm

Hi, Just also wanted to note that you should almost never have to use the Lexers menu. If the file type is not automatically being detected when you open or save a file please let me know what kind of files you are editing.

You can also add the file extension to the the list in Preferences->Document->Syntax Highlighting to associate it with a given file type.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Lexers menu not populated in Windows

Postby rgidney » Wed Nov 17, 2010 4:36 pm

Cody,

Yes I do add extensions to the highlighters as needed but the reason I use the customize menu is for those times, many of them, where I doing things like SQL scripts to investigate an issue or test procedures and like to have bracket highlighting and such things but do not necessarily want to save the code or will add pieces to a final documentation as I work it out.

For working with projects I have no issues.

Thanks,
Bruce
rgidney
Limited User
 
Posts: 2
Joined: Tue Nov 16, 2010 6:05 pm


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron