INstallation issues with python 2.7

Report Bugs Here

INstallation issues with python 2.7

Postby onekk » Fri Oct 22, 2010 9:13 pm

Hi to all, i've just installed Editra on arch linux system, it use python 2.7 and it is invoked with pyhton2 as the standard python installation is python3 (3.1 if i remember well).
The problem is in installing plugins using the plugin manager it find only plugin for python 2.5 and it won't install it (i need Launch plugin).

Editra is installed from source with:

python2 setup.py install --root=$pkgdir/ --optimize=1

where $pkgdir is the directory of installation

TIA for any help

Cheers
Carlo
onekk
Limited User
 
Posts: 2
Joined: Fri Oct 22, 2010 9:06 pm

Re: INstallation issues with python 2.7

Postby cody » Sat Oct 23, 2010 12:33 am

Hi,

Editra does not officially support Python 2.7 yet. (maybe for next release).

Thus the plugin manager does not have any Python 2.7 compatible plugins in it yet.

Python 2.6 is the suggested version to use for the current release.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: INstallation issues with python 2.7

Postby onekk » Sun Oct 24, 2010 4:19 am

Downgraded to python26

Many Thanks
Carlo
onekk
Limited User
 
Posts: 2
Joined: Fri Oct 22, 2010 9:06 pm

Re: INstallation issues with python 2.7

Postby odius » Fri Dec 10, 2010 4:29 pm

Do plugins still not work with Python 2.7? I just installed Editra 0.5.99 and I am using Python 2.7.1 and I see no plugins available. Thanks.
odius
Limited User
 
Posts: 1
Joined: Fri Dec 10, 2010 4:22 pm

Re: INstallation issues with python 2.7

Postby DevPlayer » Fri Dec 10, 2010 5:10 pm

Same here. Python 2.7 no internet plugins listing in Tools-Plugins; (on my dev install). On my binary install of 0.5.99 There fine.
DevPlayer
User
 
Posts: 9
Joined: Fri Oct 29, 2010 4:13 pm

Re: INstallation issues with python 2.7

Postby cody » Sun Dec 12, 2010 7:13 pm

As mentioned I have not yet prepared the PluginManager on the website with any plugins that are compatible with Python 2.7.

The Python 2.7 compatible versions will start showing up in the plugin manager over the next several weeks. Editra 0.6.0 will be the first version of Editra to officially support Python 2.7.



Cody

p.s) The current binaries are built with Python2.6 so that is why the plugins show up with that and not your source version running on Python 2.7.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron