[fixed] Projects plugin not working with Editra 0.5.15?

Report Bugs Here

[fixed] Projects plugin not working with Editra 0.5.15?

Postby jaxom » Tue Nov 03, 2009 9:43 pm

Hi!
I try to get the latest Editra working together with the projects plugin and Subversion version control on Windows Vista and Windows 7.
I can't get it working. Can anyone confirm this? I configure the svn binary and Repository but get no svn status displayed for my projects files. And in the context menu for a file in the project browser all the svn options are inactive.
My TortoiseSVN svn tool is working flawlessly.

Is it just me or can someone confirm this problem?

Thanks!
Thomas
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Tue Nov 03, 2009 10:05 pm

Hi,

Works fine on my systems. Here are some things to check

Did you have a previous installation that worked, or is this your first installation.

What svn binaries are you using? Is the path to the svn binary correctly set in the Projects configuration? (most the time you shouldn't need to configure the repository settings, especially to just get status updates).

Open View->Shelf->Editra Log, and see what messages are posted to the log when you expand a folder in the Projects window tree.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Wed Nov 04, 2009 6:43 am

It is a fresh install. I tried it on a Windows 7 system and on a Windows XP system with the same results currently.

My binary is this: C:\Program Files\Subversion\bin\svn.exe
Subversion-Kommandozeilenclient, Version 1.6.6.

In the Editra log there are lines like this when opening a directory of my project:
[07:36:35][projects][info]P:\svncopies\svndbdt C:\Program Files\Subversion\bin\svn.exe status -v --non-interactive -N --username jaxom --password secret .

If I execute these commands in a command window then the files in the directory are listed.

And in the plugin configuration I configured a repository of this kind: "svn://domain.de/project/"

Any idea?
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Wed Nov 04, 2009 3:34 pm

Hi,

Just tried a clean install on my Windows machine and it is indeed not working there.

It appears that the windows installer incorrectly installed the support files for the spell checker in the base of the install directory (spell checking is new this version). Having the files there appears to have a strange affect on the projects plugin and Launch plugins.

As a workaround till next version remove the following files from your top installation directory (i.e C:\Program Files\Editra):

* All .py and .pyc files
iconv.dll
intl.dll
libenchant.dll
libglib-2.0-0.dll
libgmodule-2.0-0.dll


After you remove those it should start working. I still need to investigate why those files being there had such a subtle affect on the use of the subprocesses that run the source control and launch commands.

Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Wed Nov 04, 2009 4:01 pm

Great - it works now!
Thanks!
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Thu Nov 05, 2009 7:26 pm

I just tested some more: The version history seems still not to work. A window is displayed for the version history, but there won't show any history information...
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Thu Nov 05, 2009 8:25 pm

Hi,

Yes that is a known issue there is a bug report for it at editra-plugins.googlecode.com. I haven't worked on the projects plugin in awhile as I have been focusing on core functionality lately. Hoping to get to some of the project plugin bugs in the near future though.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Sat Nov 07, 2009 6:20 pm

Hi,

I went ahead and released the latest svn version of the Projects Plugin today (version 1.4). It should fix the history window issue.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Sun Nov 08, 2009 9:46 am

cody wrote:Hi,

I went ahead and released the latest svn version of the Projects Plugin today (version 1.4). It should fix the history window issue.


Cody


Hi!

I updated the plugin and afterwards the svn version control stopped working completely. Before the update the svn file status etc. was shown in the projects file browser, and after updating no status information any longer is displayed.
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Sun Nov 08, 2009 5:37 pm

Hi,

Sorry, seems I need to have more help testing on Windows. There was some differences in how some subprocess methods are supposed to be used on windows it would appear. Should be fixed in version 1.5.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Mon Nov 09, 2009 5:57 am

Yes, it works better now!
And the Revision History is now indeed displayed correctly.
BUT:
I selected a revision in the window and dared to click on "Compare to Selected Revision"
Then the windows hangs on "Retrieving File History..." - nothing happens.
Sorry for having still bad news ;-)
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby cody » Mon Nov 09, 2009 1:40 pm

Hi,

Works fine for me on all accounts.

Do you have a merge/diff program configured in your settings? Anything in the log when you try to do a compare from the history window? (its basically doing the compare to previous command that is in the main projects window.)


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: svn in Projects plugin not working with Editra 0.5.15?

Postby jaxom » Mon Nov 09, 2009 6:36 pm

For me it works on some files of my project and not on some others.

What I see in the log window are lines like this for every file I select "Compare to last revision":
P:\svncopies\svndbdt C:\Program Files\Subversion\bin\svn.exe cat --non-interactive --username jaxom --password secret index.php

The problem occurs only with the internal diff. This seems to have problems with project files with many revisions in their history or with bigger project files - I can't exactly say.

With an external diff command these problems do not occur.

So I'll use an external diff then :-)
jaxom
User
 
Posts: 7
Joined: Tue Nov 03, 2009 9:34 pm


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron