Hangs on startup

Report Bugs Here

Hangs on startup

Postby phavx » Wed Oct 28, 2009 11:42 pm

hello,

just installed Editra(0.5.05) via the ebuild provided by Gentoo, but it's hanging on startup.

Some info:

sys: Gentoo GNU/Linux ~x86 (x86 unstable)

dev-lang/python-2.6.3 USE="ncurses readline sqlite ssl threads xml -berkdb -build -doc -examples -gdbm -ipv6 -tk -ucs2 -wininst"

x11-libs/gtk+-2.16.6 USE="jpeg -cups -debug -doc -jpeg2k -test -tiff -vim-syntax -xinerama"
x11-libs/wxGTK-2.8.10.1-r3 USE="X pch -debug -doc -gnome -gstreamer -odbc -opengl -sdl
dev-python/wxpython-2.8.10.1 USE="cairo -doc -examples -opengl"

All packages build with:
CHOST="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -fomit-frame-pointer -pipe"
LDFLAGS="-Wl,--hash-style=both -Wl,-O1 -Wl,--as-needed -Wl,--sort-common -s"

Starting Editra (with -dd) goes til "starting up ipc server", the splashscreen comes up as empty window(i.e. only the background-color defined by the gtk-theme is visible), the process goes up to 100% cpu and stays like this til getting killed by me.

appreciating help :)
phavx
Limited User
 
Posts: 2
Joined: Wed Oct 28, 2009 10:54 pm

Re: Hangs on startup

Postby cody » Thu Oct 29, 2009 12:11 am

Hi,

Haven't seen this happen before,

What version did you upgrade from? Or is this first install?


1) Try Starting with the -S option to disable the ipc server to see if its at fault

2) Try deleting your preferences directory (~/.Editra)


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Hangs on startup

Postby phavx » Thu Oct 29, 2009 12:27 am

wow, you're quick :)

first and fresh install, just stumpled upon it by looking at portage's output while syncing.

it seem's that indeed the ipc-server is the problem, '-Sdd' brings it up successfully and shows no other errors(well, except on GTK-error) and this way CPU-usage is also back to normal.

thanks so far, now I'm able to test it. let me know if/how I can help finding the exact problem.

cheers, good night and greetings from .de,
phavx
phavx
Limited User
 
Posts: 2
Joined: Wed Oct 28, 2009 10:54 pm

Re: Hangs on startup

Postby cody » Thu Oct 29, 2009 12:56 am

Hi,

The GTK errors are harmless and can be ignored.

Odd, will have to investigate not sure why the ipc server could cause this to happen. All it does is open a socket connection on the local loopback address and then sleep until something trys to connect to it.


Thanks for the info,

Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron