problem when typing greek letters in Linux

Report Bugs Here

problem when typing greek letters in Linux

Postby pmav99 » Sat Oct 03, 2009 10:16 pm

Hi,

I have a problem with typing greek letters in Editra. When you start typing a phrase (say "Το πρόγραμμα αυτό υπολογίζει ..." everything is ok until you make a typo. Then, if you press backspace to correct it, you can't continue to type in greek. You press keyboard buttons but nothing happens. Nothing appears on screen.

I've found two dirty hack for this:

1. If you change your language layout to english and then back to greek you can continue to type. Until the next typo... It' s not very cumbersome but it is rather annoying.
2. If after backspace you press space you can continue to type. But of course this means that there will be a space in the middle of the word... In order to correct the word you have to erase the whole word and write it again. Not very user-friendly...

The strange thing is that this behaviour appears to happen only in Linux (I've tested on Arch linux - Editra 0.4.9 if i remember correctly, and in Ubuntu 9.10 - Editra 0.5.05), on windows there is no problem - the behaviour of the greek language is absolutely normal.

That's from me. If you need any more info just tell me.

Oh! The encoding i use is utf-8 but this behaviour appears to happen even in new (unsaved) files so it is propably irrelevant.
pmav99
User
 
Posts: 6
Joined: Mon Sep 28, 2009 4:24 pm

Re: problem when typing greek letters in Linux

Postby cody » Sun Oct 04, 2009 4:37 am

Hi,

I think that this is an issue with the version of Scintilla that is currently in use. I am hoping to get an upgrade soon when wxPython2.9 is out. Scintilla's IME support on Linux and OSX is not as good as it is on windows but there have been improvements in recent versions that may hopefully have fixed this.


Cody
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: problem when typing greek letters in Linux

Postby Nikolay » Thu Jan 21, 2010 12:12 pm

Hi, I also have this problem when typing Russian letters.

Use: Linux (ubuntu 9.10), Editra 0.5.32
Nikolay
Limited User
 
Posts: 1
Joined: Thu Jan 21, 2010 10:54 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron