Don't display the characters '[' and '{' on Editra MAC

Report Bugs Here

Re: Don't display the characters '[' and '{' on Editra MAC

Postby zeoculls » Tue Apr 21, 2009 1:56 pm

No, everything remains same, and with keybingings coul you fix it ? :(
zeoculls
User
 
Posts: 8
Joined: Thu Jan 15, 2009 1:40 am

Re: Don't display the characters '[' and '{' on Editra MAC

Postby xamako46 » Thu Sep 15, 2011 8:19 am

Any solution for this bug?¿

Thanks!
xamako46
Limited User
 
Posts: 2
Joined: Thu Sep 15, 2011 8:03 am

Re: Don't display the characters '[' and '{' on Editra MAC

Postby cody » Thu Sep 15, 2011 1:21 pm

Hi,

No unfortunately I don't know whats wrong other than it appears to be a bug with the wxStyledTextCtrl which is used for the text buffer.

This may be fixed with the newer version of it in wxPython 2.9. I don't have a keyboard/computer to test to reproduce this issue so it is hard to debug or test to make any progress on it. If anyone wants to see if it is fixed in wxPython 2.9 you can install Python2.7 / wxPython 2.9 (wxpython.org) and then just download the Editra source bundle and run (python editra) from the commandline to try it out.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Don't display the characters '[' and '{' on Editra MAC

Postby xamako46 » Thu Sep 15, 2011 1:39 pm

Hi,

I've changed to use TextWrangler

I'm web developer and I need these characters, and I can not wait

thanks!
xamako46
Limited User
 
Posts: 2
Joined: Thu Sep 15, 2011 8:03 am

Re: Don't display the characters '[' and '{' on Editra MAC

Postby cody » Wed Nov 09, 2011 7:18 pm

Forgot to update here but I found a possible fix in the wxWidgets code and have attached a patch at the following ticket:

http://trac.wxwidgets.org/ticket/9663
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Don't display the characters '[' and '{' on Editra MAC

Postby Pirer » Wed Aug 27, 2014 3:38 pm

Hi,

I want to reactivate this old post because I still have the same problem: some characters can not be written.
I will describe it as best as I can to see whether it helps to solve it.

I am using a Editra 0.7.20 in a MacBook Air (2013), with OSX 10.9.4. The keyboard has a spanish layout (with the configuration Español - ISO).
This keyboard has two keys that do not work properly in the main text window of Editra (EditPane).


The keys, (1) and (2), are:
(1) ` ^ [
(2) ´ ¨ {

Where the first character is the standard character, the second one appears when the SHIFT key is pressed, and the third one appears with the ALT key pressed. In both (1) and (2), the first two are dead keys, though I suppose this is not important.

When I press one of these keys, they behaves as the BACKSPACE key (i.e. it deletes the previous character). When SHIFT or ALT are activated, they do nothing (in contrast with the real backspace, that deletes the previous word with ALT pressed and does nothing with SHIFT pressed).


However, those keys work properly in other panes in Editra. Specifically, they work well with the Editor Command or in the Preferences Pane (e.g. in the text inputs in the Network submenu).

I have tried to change the local settings (the language) to English U.S., Spanish and Catalan. None of them made the keys work.


If you want some more specific details or you want me to perform some tests, I will do them as soon as possible.

Cheers.
Pirer
 

Re: Don't display the characters '[' and '{' on Editra MAC

Postby cody » Fri Sep 19, 2014 2:07 pm

Hi,

I found the solution for this problem several years ago, the issue was in wxWidgets, I submitted a patch to them to correct this problem and to my memory never got a reply on the patch.

I have not worked on this project in some time, but if you want you could try to run Editra from the source package using wxPython 2.9 or later to see if it still runs there and to check if wxWidgets project has integrated a fix for the issue yet or not.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Re: Don't display the characters '[' and '{' on Editra MAC

Postby Pirer » Mon Sep 22, 2014 12:24 pm

Hi!

You were absolutely right, thanks for your help. They fixed the problem because the aforementioned keys are now working properly.

I will write down here what I did to help anyone else who will find the problem without knowing how to solve it:

(1) Go to http://www.wxpython.org/download.php#osx and download the last version of wxPython. In my case, the version of wxWidgets that wxPython has intalled is 3.0.1.1 (it can be checked by typing in terminal "python", "import wx", "wx.VERSION").

(2) Download the source code of Editra from http://editra.org/download.

(3) Unzip and execute from terminal the script "editra" (that is, type "./editra").

(4) To create an OSX application (to get the icon in the App folder), you should follow the instructions corresponding to Option 4) in the INSTALL document within Editra's source code downloaded in step (2).


Thanks again,
Pedro.
Pirer
 

Re: Don't display the characters '[' and '{' on Editra MAC

Postby cody » Tue Sep 23, 2014 1:50 pm

Great!

Good to know they finally fixed it 3.0.
User avatar
cody
Site Admin
 
Posts: 1315
Joined: Mon Oct 09, 2006 2:49 am
Location: United States

Previous

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron